Magento 2.4: что нужно знать

Состоялся релиз Open Sourse Magento 2.4.0. Это очередное крупное обновление популярной системы для эллектронной торговли. Как обычно, обновление содержит в себе ряд улучшений по безопасности и производительности.

Magento поддерживает PHP 7.4.. Можно установить Magento 2.4.0 на версию PHP 7.3, но не рекомендуется.

https://devdocs.magento.com/guides/v2.4/install-gde/system-requirements-tech.html

Кроме новой версии PHP, появилась поддержка:

  • Elasticsearch 7.6.x — поисковая система магазина по умолчанию как в Magento Commerce, так и Open Source.
  • MySQL 8.0, хотя MySQL 5.7 все еще поддерживается, а если вы использовали MySQL 5.6 — прийдется переезжать. Также, есть поддержка MariaDB 10.4.
  • PayPal Javascript SDK последней версии,
  • Magento Functional Testing Framework (MFTF) v3.0.0 включает новые функции и поддержку PHP 7.4 и PHPUnit 9.

Что изменилось в Magento 2.4?

Прекращение поддержки и удаление мастера настройки через веб интерфейс. Для установки или обновления Magento 2.4.0 теперь можно использовать только командную строку.

  • Усовершенствованная система управления запасами, которая теперь поддерживает самовывоз из магазина.
  • Для администраторов доступна двухфакторная авторизация (2FA).
  • Миграция зависимостей с Zend Framework в Laminas. Это было ожидаемо.

Помните, Adobe купила Magento? Так вот, в версии 2.4 добавлена Adobe Stock Integration v2.0. Прямо из админки можно найти любое изображение из Adobe Stock в галерее, что делает удобной покупку стокового изображения прям из админки магазина.

Полный список изменений и обновлений можно посмотреть на официальном сайте.

Default image
Агентство интернет-маркетинга
Агенство эффективного интернет-маркетинга предлагает услуги по созданию, оптимизации и продвижении вашего ресурса в интернете.
guest
0 Комментарий
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x